How the hell do I get Cisco VPN off my PC


#1

I need to upgrade my Cisco VPN software, but it is convinced that there is a previous version that is awaiting uninstall. I followed all the instructions on this page and deleted all vpn related cisco reg keys, but I am still getting a 28005 error during install:

Since I don’t have access to submit a ticket to Cisco and MIS is clueless, does anyone have any suggestions on what could still be causing this? I had uninstalled the previous vpn months ago. I tried reinstalling it, but it returned the same error.

Windows XP 32 bit, btw.


#2

The Windows MSI Cleanup Tool (here) may help.


#3

Thanks for the suggestion. It unfortunately shows nothing out of the ordinary.


#4

I wish I had advice here Cat. The page you linked took care of the few issues we’ve had with older clients. In addition to deleting the reg entries we also cleared the associated directories, then rebooted and had no issues.

Did you, by chance, get an error when trying to delete those reg keys saying it couldn’t be deleted? Better yet, you may need to verify that the attempt to install isn’t still running as a process, preventing a newly clicked install from running.


#5

Read a thread where (after Cisco’s solution failed them) a user got past it after using a registry cleaner like this one: http://www.winaso.com/

I seem to recall having a very similar problem years ago at a client I worked for. Fortunately, we had standard corporate images so we didn’t worry about it too long before we blew it up and moved past it.


#6

Seconded - you need to clean it out of the registry with a wire brush.


#7

Indeed. There are plenty of registry entries associated with calling things in .dlls without using the name of the associated program itself.