It’s the 20:20 Movie Frame Game of 2021!

If by enlightening you mean no help at all, you’ve nailed it. ;-)

It’s Altered Minds, which may be Hirsch’s best performance.

You should hear my conversations with my wife. “What is that actor, whatshisname, in that movie with the red thing, you know, we watched it when we were visiting your niece? I think he was in a TV show too, he was funny. Remember?”

And she will immediately remember who I’m talking about. I think she would destroy us all at this game.

Meanwhile I can remember the device IP addresses for things from three jobs ago. We all have our shining moments.

I see you didn’t work with IPv6. ;)

That’s a whole different ball of wax. Maybe one day when I retrain my mind.

That may be his best, but this is not that!

Hmm, this raises the question whether Hirsch wears the same sweater in all his roles.

Hm. Maybe I should’ve vetted these frames a bit better. I was sure going in one would catch something that would be a dead giveaway, but maybe not.


Let’s go with something dumb. Wasn’t he in a Sharknado movie? So let’s guess that, Sharknado… 2.

I’m pretty sure there is more than 2.

Just watched it. It truly is bonkers. There’s no plot as such. There’s a crazy cat guy. Various people show up at his place for some reason and proceed to get mauled by cats, with varying degrees of “playfulness”, and a rampaging elephant. The ones that aren’t maimed or killed - mostly crazy cat guy’s family - then inexplicably fail to leave, and five minutes before the end they decide the cats didn’t really want to hurt them, all evidence to the contrary notwithstanding, and they turn a horror film into a cutesy Disney film by force of will.

Alright, well here’s the final frame. I think just a few seconds to either side of any of these and it would’ve been immediately apparent to anyone who’s seen it, but I may have to eat the loss here.


Alright, I’ll eat the loss on this one. It’s This Must Be The Place or, Robert Smith, Nazi Hunter.

(Also: did something just change with Amazon? between Wednesday and today, I can’t seem to take screenshots of Amazon videos. I just get a black screen with either print screen or the snipping tool. Got this frame from a Google image search.)

Update Firefox and try again. It happens from time to time. Chrome goes back and forth with it as well, most of the time it doesn’t work, then it will work occasionally. I just tried and I’m able to capture from Amazon using the latest Firefox version.

That movie though, I’m going to need a review. Said character on that last frame is Sean Penn?!?!? And the movie also has Frances McDormand? Was it good?

It’s not bad? I guess I’d go so far as to call it good. Mostly.

Sean Penn plays a retired musician who is more or less Robert Smith, and after his estranged father’s death discovers, he had been a holocaust survivor. So Sean Penn decides to take a road trip across America to track down one of the Nazis that tormented his father in the camp.

I think it probably depends on your tolerance for Sean Penn’s performance. It’s very lowkey and odd, and I think it could easily be insufferable for many.

I tried with both Chrome and Edge last night, but I’ll give Firefox a try next.

Sorry folks, neither Amazon nor Netflix wants to cooperate with my screenshotting. I’ll keep at it and see if I can figure something out…

No worries, man. If needed I have both of those and will bow out to assist on screenshots. Ping me the title in PM.

What about the snipping tool? Assuming you’re using windows, don’t know if MacOS or Linux have an equivalent.

The new 20:20, frames courtesy of @Skipper .

It’s gotten so bad the only thing I can get to work anymore is Firefox for the viewing, and SnagIt for the screenshot. I think it’s Firefox that’s the key, I’m betting even the windows screenshot tool would work with it too. But for sure, everything worked a couple of years ago. Now, not so much.

Dang, that sounds quite frustrating. It’s been awhile since I did any frame grabs for the game, but I do recall running into problems with Amazon, where I ended up needing to use the snipping tool and sort of “bootleg” the screen grab. Direct screenshotting/print screen just wouldn’t work for some reason.