[Review] Midnight Protocol hacks into the sweet spot between storytelling and strategy

Can you post screenshots of your [L]ogs screen and your [A]ddress screen? Or at least tell me what information they’re giving you? If it’s not a bug, I’ll get you past it.

(I just re-played up to that point, but I’m not sure where the saved game files are.)


So the actual gameplay is often an exercise in doing the best you can with the tools you’ve got. That’s the second source of tension. Which wouldn’t work if you could just hack into a server, take a look around, then back out to get the tools to best beat the server.

Uh, Tom. You can.


Seems to me you should definitely have Addresses for Encryption I and Bridge I at that point in the game. Can you just verify that you’ve read/responded all your emails? There shouldn’t be any dots indicated unread or unreplied email. Here’s what the [E]mail screen should look like:

MP email

Let me figure out where the saved games are located and I’ll post a link for you.


I played the Demo only and got to a point that I see in @Sonoftgb is seeing. I figured that was the end of the demo. Though it seemed like there should have been a screen that said that the demo was over. Now I am wondering what happens at the end of of the demo. Did I run into the same bug and never finished the demo?

Otherwise if that screen is the end of the demo maybe @Sonoftgb is stuck on the demo version thinking it is the actual game. I know I have run into things like that in the past (playing what I thought was the game). Anyhow this is a long shot and I am probably off base.

Here’s a saved file, to be put here:

C:\Users\yournamehere\AppData\LocalLow\LuGus Studios\Midnight Protocol


The demo was more fun than I expected. I may pick up the Humble Monthly for this. I actually got excited when I opened the vault with the password.

Thanks for the review @tomchick, I have not had this much fun with a hacking game since Introversion’s Uplink.

Thanks for the save. I’ll check it out later. For the record my email does have a dot indicating unread email, but everything has been read and responded to.

@geewhiz brings up a good point, since I did play the demo a couple of weeks before purchasing, but only long enough to determine this is something I wanted. I uninstalled it prior to purchase, but maybe some residual file is mucking things up

That’s high praise. In many ways Uplink still is the golden standard in this genre.

I’ll definitely get this when it gets a discount. No rush. ;)

I was reading about @Sonoftgb issue and was wondering…

I installed the demo and played through everything. Then I uninstalled the demo and am getting ready to activate my Humble key. Are there any files I need to clean up manually to avoid any issues? Has anyone played the entire demo, uninstalled it, and installed the full program without issues?

Sometimes you need to send emails, too. It’s a separate tab in the email application. I don’t remember if that was part of the flow at that stage of the tutorial, but you might check.


I was thinking of keeping the Demo installed purchasing the game and see what happens.

I mentioned this before, and he said in the post you’re responding to that he answered all the emails. But in the screenshots he posted, the first one looks like he has an outstanding email issue. The dot next to [E]mail is clearly saying that’s where he needs to go to progress the game. But then the dot is missing in the second screenshot he posted, where he’s not showing Bridge or Encryption in his [A]ddress list.

@Sonoftgb, did you make any progress with the saved game I posted? I’m really curious to find out what was going on with your game, whether it was a bug or a feedback issue.


Sorry, Tom. We just found out about a major SNAFU in our immigration status, and it needs to be cleared up today or tomorrow. I’ll get back to the game as soon as I can.

I purchased the game and installed without removing the demo version.

When the actual game installed it automatically removed my demo icon on my desktop and replaced it with the new icon.

When I started the game my save slot 1 from the demo was still listed but the game would not allow me to play it. I had to start on a new save slot and the game has worked as expected.

Good luck, I hope it can be worked out.

Sounds good. Thanks

Question about one of the early missions Treasure Island


Is taking money from these financial nodes stealing from Clover? It sounded that way from the message I got when I broke into the Vault in “The Playground”.

Thanks, it will be. It’s just a huge PITA to deal with