Rise of Legends claims "firewall" is blocking -- just started

MAF has this same problem with starting/connecting to a multiplayer game on Rise of Legends, too, and it just started the other night.

Pre-emptively: my machine is CLEAR. I am paid big bucks to be a networking guru. I have written networking software and documentation professionally for over seven years. Don’t go there.

I am not running Windows Firewall. All the correct ports are forwarded on my router. I had made no networking changes and, as far as I know, installed no new patches to XP. The following behavior simply started last night when I attempted to create a multiplayer RoL game to play with MAF. Conversely, Dungeon Siege 2 plays fine.

Anyway, I whack the Multiplayer->Online button sequence when my screen goes black and then I get the following message:

“Rise of Legends cannot connect to the Internet; a firewall is probably blocking it. To continue, grant network access and then click OK.”

What the fuck – was there a stealth patch to this game or some recent XP update that might’ve caused this? MAF gets the same message at the same time – occasionally we connect, but then we hang. All I can think is that I’m running Teredo for a few test apps but I know MAF isn’t doing that, and it’s never been a problem before. I’ve scrubbed my network service list and I’m SURE all the correct ports are open and forwarding both UDP and TCP (although only UDP is required according to Bug Huge).

Is there a server issue at Big Huge?

Welcome to Gamespy. Please be sure to bring your own KY Jelly. Please make sure to remember that the fault is always with the user. You are guilty of “erroneous configuration”. Thank you, please drive through.

Great game, exceedingly poor multiplayer connectivity. Its sad really.

Also, been there, thread that: http://www.quartertothree.com/game-talk/showthread.php?t=26584


Fuck, the WHOLE online infrastructure uses Gamespy? I thought it was just for the friends list. WTF.

Guess I’ll just wait for the problem to clear itself up. :(

haha clears itself up. :( I wanna play

Yeah, my Alin game is getting good and I wanna keep my skills fresh. I suppose I could host a LAN game and turn the port forwarding back on, but I like to keep my router tidy.

bleh, screw you gamespy

Welcome to the club. I just tried playing Rol again with the new patch, and it still won’t let me play any custom matches.

Yeah, you gotta wonder what’s going on behind the scenes. The Gamespy networking seems deeply borked even now, and not just for a few users. I don’t know any ROL player who’s had a trouble free experience, although the level of trouble varies. The thing that gets me is this is a fairly major release from a very reputable and thus far successful developer, who had Microsoft backing, and the Gamespy networking was still crap. Keep in mind there had been issues with RoN and Gamespy and especially with Dragonshard and Gamespy. And the BHG rep indicated in that thread 3 months ago that they would be working on this as a priority. And yet, the problem persists nastily.

If I were Microsoft I would be very very displeased with Gamespy, or possibly with the net-coders at BHG (I don’t know who is to blame precisely, but somebody is!).

You know what’s odd? RoL ended up being a big enough disapointment that I’ve gone back to Kohan 2, which remains my favorite RTS of the last couple years. Amazingly given the low sales of the game, there is still an online community. Small, sadly, but very very dedicated. And the game is reasonably stable on Gamespy, with some occasional problems.

Buh, RoL is amazing, the multiplayer has been good for me up to this point, so thats like 3-4 months of awesome.

Kohan 2 was KAG stripped of anything I liked and built ground up for critics.

I like how KAG got tons of actual awards for being an awesome game, Kohan 2 got middling scores and barely any awards, if any, and people still say its better.

K2 made me die inside.


Why didn’t BHG work with Ensemble via the MS CONNECTION and use Ensemble’s AoE3 matchup service?

Kohan 2 was soul-deadeningly inferior to KAG. Gitcher Blizzard outta my Kohan!

RoL is still getting an expansion right?

Maybe the expansion will offer a different network for games lol

wouldn’t that be swell!

Where is that? Because I tried logging on 3 times at random times, and no one else was on at all.

The issue is related to a patch server problem that occured due to hardware malfunction, and the backup is taking time to DNS propagate. In the interim, the “firewall detected” message is popping up for a number of players. Clicking “Okay” several times on the error message should allow you to eventually log in to the multiplayer interface.

We do apologize for this unexpected downtime, and we are taking steps necessary to ensure that it does not occur again.

Warm Regards,
Joe “GreyPawn” Pishgar
Community Relations Manager
Big Huge Games

“Warning: Cat-like programming detected”.

I’ve clicked “okay” several times and it still hangs at the little “running silhouette” connection box.


I’m looking forward to Rise of Nations: Rise of Legends: Rise of Zeke.