Skyrim Anniversary Edition adds fishing and probably a ton of new bugs

I know the gameplay in Skyrim is much better with the controller of course, compared to mouse, but then is the SkyUI interface that much better than the regular interface if you’re using a gamepad? I had always assumed SkyUI was for people who didn’t play with the controller.

Absolutely! The default interface is still a pain with controller, compared to SkyUI.

In default, to change inventory categories you have to back out of the inventory items, move up/down, and select a new category to filter.

In SkyUI you use the bumpers while the inventory stays open. Here’s an image I found comparing the two, where you can also see all the additional info available at a glance in SkyUI, never mind it fits way more items on the screen too:

The new version of SKSE is up.

I “upgraded” to the newest version because I was like cool I will just play it and not add even more mods. I played for an hour and had like 10 things that I felt I needed to go back and add. And down the rabbit hole I go again. ;)

Dear god, looking at that screenshot I am reminded just how shit Bethesda’s UI is. What a fucking joke.

Heh, I tried the same on XSX and ended up installing some basic QoL mods just to keep my sanity. “You don’t know me” and “Rich merchants” are must-haves for me. There’s a few others I threw on there but I didn’t install any of the biggies like the unofficial patch or any huge weather mods or extra quests this time around.

One thing I did notice is that with the creation club mods, I keep stumbling across player homes. I’ve got a farm, a mage crib, and a vampire lair. My immersion is a little broken because of this. I need to either restart from an early save, or just forget about these other dwellings and just do the DLC one. My character is just wandering aimlessly at the moment with lots of houses and coin. Oh, and he’s the Arch-mage. Man, I wish there was an option at the end of the Mages Guild questline to just turn that title over to someone else.

I’m so used to Morrowloot (change leveling and loot tables) and Ordinator (perk trees that suck less) and whatever the awesome magic mod I use is (tons of new and rebalanced spells) I don’t think I can go back. Anyone have any mods that serve similar purposes that are worth exploring?

There used to be a mod called Smart Cast, that let you cast spells without having to equip them to a hand…stuff like buffs and heals. It was fantastic for playing something like a 2h melee/paladin type character. Being able to cast that stuff without constantly switching out your weapon was a real game changer. It’s a mod I literally won’t play the game without, but no idea if it works with current versions.

There is a mod out there that will let you select what creation club mods you want enabled. Which is hilarious, but true. I haven’t tried it myself.

So I got a bunch of pets today. They each have some kind of perk like carrying capacity or going to loot extra shit, but I’m just leaving them at my plantation to hang out. Why not? Speaking of which, I’ve planted a bunch of crops and flowers there. Why? Because I can. The one great thing about Skyrim is that I can come off a button-masher like Avengers, and just wander around, plant shit, and chill. Plus I grabbed a mod with LOTR gear so I have a new sweet looking sword.

Much easier nowadays. A ton of wabbajack packs now simply no longer exist because of the stupid update.

I’m not seeing any that were up and current from the month before the update that aren’t there now.

Serenity II, The Phoenix Flavour, Librum, Streamlined Skyrim, Slidikins, Living Skyrim, Path of the Dovakhiin, Elysium, Legends of the Frost…

Total Skyrim Overhaul is down for maintenance, but it was down for maintenance a few days before the update.

I’m mostly saddened by the loss of Qwest!. It was the only modpack that had a focus on Legacy of the Dragonborn, but didn’t require a Cray supercomputer to run. It was a perfect mix of content additions without throwing in every 8k texture pack, survival mod, or dark souls combat.

All current packs with LoTD require 6GB+ of VRAM, and all the ones that don’t are dark souls/survival overhauls.

It sounds like Qwest’s demise wasn’t entirely because of Anniversary Edition but because it was possibly too much to maintain. I’m still going to whine about it though!

I may be totally clueless (Ok I totally am), but everything I installed seems to be working fine. The only one that I know can’t be 100% updated is the Ordinator mod as there’s a patch that currently won’t work. There’s a conflict with that mod and some other mod I have. Not a big deal. It’s nice diving into this sandbox again. I haven’t touched this game in a long time so I’m not even sure what is the mods and what is the base game anymore. Which is a good thing.

Let me know when it’s safe to play, I’ve inexplicably decided I need to bounce off this for the 5th.

That was 14 days ago. I don’t know it’s been fixed, but I just played last week with SkyUI working just fine.

I know, but if I trick KS into telling me it is safe, I can complain to him if I find even a single bug in my Skyrim playthrough ;)

It’s been fixed, you’re good. You can blame me if you have bugs in Skyrim, or any other game you play! :)

Everything looks fine. I installed it once a while ago to see if SkyUI worked and uninstalled everything after confirming it did.

Tons of mods are updating still, I don’t know what you’re looking for, sooooo. You probably have to suffer with waiting or trying things and see if they break.

That makes two of us that don’t know what I’m looking for. But thanks for the update.