The Iphone jailbreaking/unlocking thread

If I were you, I’d check the forums at to see the latest on which firmware you should get. The very latest locks you into the tethered reboot, unless someone’s fixed that by now.

here’s the fix:

then run tinyumbrella to kick it out of recovery mode.

this allows me to revert to official 4.1 by restoring it (otherwise itunes/apples forces you up to 4.2) then jailbreaking it with limera1n.

Make sure your HOSTS file has the following entry:
Shift-click Restore.
Choose “iPhone3,1_4.1_8B117_Restore.ipsw” This is 4.1 for my iPhone 4. You can download other official revisions from Apple servers through this website:
iTunes will erase and restore your iPhone to iOS 4.1 and will verify the restore with Apple.
After it finishes, iTunes will give you the following error:
The iPhone could not be restored. An unknown error occurred (1004).
Shutdown TeamViewer or any other VNC host you have running then run TinyUmbrella. (tinyumbrella-4.21.02.exe is current at time of writing)
Expand the Recovery Devices and select your iPhone then click Exit Recovery. Close TinyUmbrella.

Too late! I tried a few things and ended up restoring stock 4.2.1 to fully recover. At least the phone works again. But thanks rei for the instructions. I think my mistake was not setting the hosts file at all… Anyways I will keep it clean for now, and wait for news of an unlock that doesn’t need the ipad baseband.

Full story, recorded for giggles:

Started with 3.1.2 blackra1n tethered jailbreak and blacksn0w unlock.

  1. Saved SHSH using Cydia app. (protip: this didn’t actually work. It is way too late at this time to make the SHSH for a phone running 3.1.2, since Apple servers will only respond to the latest OS version only.)

  2. Ran limera1n to convert to untethered jailbreak, without upgrading the iOS. Phone goes into reboot “plug into iTunes” picture mode (recovery mode).

  3. Ran tinyumbrella to “exit recovery mode”. The phone exited the mode, then rebooted back into it. Still stuck with the iTunes picture.

3a. Tinyumbrella didn’t show any saved SHSH, so I assume that Cydia didn’t save my 3.1.2 SHSH. (I think I understand why now, as I mentioned above.)

  1. Followed this last ditch effort steps. Amazingly my phone passed all the prerequisites, so I gave it a try, and even though I was using some old iTunes 9.0.something, it verified the custom IPSW with Apple, which of course rejected the file.

4a. read that saurik blog entry #12. Explained things better than any other random forum posts. Finally figured out what SHSH is.

  1. Shift-click restore 4.1 stock using same iTunes. Apple rejected that, too. (Maybe it would have worked if I made the host file mod here.)

  2. Changed back to the original computer with latest iTunes, restored the phone to 4.2.1. First try failed. Rebooted computer, then 2nd try successful.

damn, shouldn’t restore to 4.2.1, now it can’t be jailbroken for now.

Yeah, you GOTTA do the hosts file thing so that Itunes grabs your SHSH blobs from the Cydia server instead of from Apple.

I think.

no, it’s just that it won’t let you restore to an older 4.1 with the official hosts.

That’s right. Something I didn’t see explicitly mentioned by anyone is that Apple is only signing the latest version of any iOS file. Therefore, no one can officially install anything except for the latest software.

From what I understood before, switch the hosts to Cydia will only work if I had previously asked Cydia to get my SHSH from Apple, at the time when 4.1 was OK. Since I didn’t know about this stuff until now, I’m screwed. Well, maybe 4.2.1 is on file now…heh.

So I am running 4.2.6 is there a good way to Jailbreak this yet? I guess that 4.3 is out now but I am not sure if that gives any big upgrades for iphone users.

I think greenp0ison works. 4.3 avoid for now.

Yeah after doing some research it looks like the JB for 4.3 should be out next week sometime but the CDMA 4.3 hasn’t launched yet so it really doesn’t matter. I am going to wait to JB till 4.3 hits so I won’t have to worry about it for a while.

Alright, 4.3.1 Jailbreak (GSM) is out and successful. I’ve got my HDMI mirroring, hotspot support and BiteSMS + TruPrint. Life is good. Not all of my previous Cydia apps work though (like Action Menu Plus Pack etc.) but this is much better than 4.3 vanilla.

Some links to incompatible apps:

I’ll miss my PhotoAlbum+, Infinidock for now.

I got bored and decided to upgrade to 4.3.1 and jailbreak/unlock. I think I’m successfully jailbroken, but the phone won’t show me anything other than the screen to slide the switch to make an emergency call. I can’t get to the springboard to download Ultrasn0w to unlock in.

Any ideas?

you might have screwed it. the unlocked ultrasn0w is defeated by protections in the new upgrades to the baseband.

i am not sure how you did it but you should have not upgraded to 4.31 directly but done some sort of custom-firmware-making process using sn0wbreeze or something where it preserves your current baseband by slipstreaming the haxors into the official firmware.

i no longer actively use or update my 3g or 3gs so i don’t know what is involved. i know my 3g once i updated it to 4.21 i can’t use ultrasn0w to make it carrier-unlocked anymore.

Actually, I did use a custom firmware created with Sn0wbreeze 2.5.

I may try a different JB tool.

UPDATE: Redsn0w seems to be doing it. It’s in progress right now.

ANOTHER UPDATE: The newest version of Ultrasn0w will unlock your 3GS with the 4.3.1 FW.

I followed this guide to jailbreak my iPhone 4 running 4.3.1

BiteSMS is such a huge improvement it blows my mind.

LastApp is freaking great.

I recently upgraded and re-JB’d my phone (that sounds nasty). I think I redownloaded and installed BiteSMS, but I don’t see it. I forget - does it have an icon?

EDIT: Never mind. It’s not in my list of installed packages in Cydia. Duh.

Here’s my current 4.3.1 jail-broken app/tweak loadout:

AutoResponder ($1.50) - automatically respond to SMS text messages with presets or a custom one
BiteSMS ($8.99) - awesome SMS app
Browser Changer (free) - change your default browser, mine’s set to Atomic
BytaFont (free) - change your system font, I change mine to the “Aller” font
FolderEnhancer ($2.99) - add multi-pages to app folders as well as other tweaks
iClassic ($2) - music playback app that emulates clickwheel iPod interface
Icon Renamer (free) - self-explanatory
Infinidock ($0.99) - have multiple docks
LastApp (free) - easily switch to the last app
LockInfo ($7.99) -
-Weather Plugin for LockInfo (free) -
ManualCorrect Pro ($0.99) - a better spellcheck autocorrect tweak
Mark Read ($1.99) - Mass mark read/unread messages in
MultiIconMover (free) - move more than 1 app icon at a time
Notified Pro ($2.99) - awesome notification system replacement
-Notification GRIP for Notified Pro (free) - Growl style bubbles
PhotoAlbums+ ($4.99) - add, edit photo albums on-the-go
PkgBackup ($3.99) - backup your Cydia apps
SBSettings (free) -
-Remove Background SBSettings toggle - shutdown all background apps
-Push Notifications toggle
-iRetina ($1.99) - HD theme for SBSettings
ShowCase (free) - display lowercase on the keyboard
Springtomize ($2.99) - extensive amount of tweaks
TruPrint ($9.99) - expand AirPrint support to non-official AirPrint printers
WinterBoard (free) - skin/theme system
-Better White Icon Labels (free) - used with WinterBoard
-Blue Battery for iPhone HD (free) - changes the green charging battery to blue
-Tweetie SMS HD (free) - changes SMS chat bubbles and buttons