Turbine accounts may be hacked

Got this in my mail today, so you might wanna go change that password as well, in case you have any turbine games

Turbine is concerned that a third-party recently may have attempted to access forum account information. There is no indication at this time that your account was modified or compromised. For your protection we suggest you change the password to a unique, hard to guess password not associated with any other sites or services. If you changed your password after October 11th, then you can disregard this message.

To change your password, please follow these steps:

[li]Go to link removed and click on “Forgot your password?” You may also click this in the game launcher.[/li]> [li]Follow the instructions on how to recover your password. A new password will be sent to this e-mail address.[/li]> [li]Once you have received the password reset e-mail, change your password. Please remember to use unique, hard-to guess passwords that are not associated with other online services or sites.[/li]> [/ol]

Seems to be the reason the forums are down now for over a week both at DDO and LOTRO

Or simply navigate to your Turbine account URL, log in through “Manage turbine account” and select to change your password using the relevant tab at the top.

Just took care of mine. You can never be too careful.


Yeah, I got that too. You know, it didn’t even cross my mind that THAT could have been a phishing email. Probably because LOTRO emails have giant blobs of art with them. But the link does just send you to the turbine page where you click “reset my password” without logging in, so it seems legit.

Nevertheless, I might just go to turbine’s page and change it again…

I have just started playing LOTRO again, is this why i havent been able to access their forums for over a week i guess?

Will change my password asap even though i didnt get the email, thanks!

No wonder they get hacked when this is the message you get when you open their web page.

This site functions optimally with Microsoft Windows Internet Explorer 6.0 or higher and Mozilla Firefox 2.0 or higher. If you are seeing this message, we have detected you are not currently using a Microsoft Windows Internet Explorer or Mozilla Firefox browser. We recommend you change browsers to ensure a clean browsing experience.

When trying to access it (support.turbine.com/ics/support/loadWidgetTab.asp?widgetID=4) with HTTPS you get:

You attempted to reach support.turbine.com, but instead you actually reached a server identifying itself as *.parature.com. This may be caused by a misconfiguration on the server or by something more serious. An attacker on your network could be trying to get you to visit a fake (and potentially harmful) version of support.turbine.com. You should not proceed.


Their header says “Powered by their fans”.
Maybe they should hire some professionals next time.

When changing passwords; this is what you have to contend with.

Must be between 6 and 16 characters in length, of mixed alpha-numeric characters only

Since I am feeling generous here are some suggestions for Turbine:

  • Forcibly redirect users to a HTTPS version of all their sites
  • Replace their javascript requiring people to use IE6 to either get IE8+,FF5+,Chrome 14+.
    In fact; the web page should not work at all for people using IE6.
  • Let people have password higher than 87 bits.

I got that email too, and all I’ve played is the LOTRO beta. For like 3 hours.

I have no idea what obscure browser or what link you are using to get the above issues. I have tried with 3 different browsers now, on 3 of their sites, with no issues whatsoever.

As for the passwords, it can include anything - I know, since I use special signs in mine.

https://support.turbine.com isn’t that obscure. I get the same.

Changed my password but realized they still had my credit card info.

When I tried to find where to remove it I found that you can’t.

And this was originally a story 4 years ago when people complained about it and it still hasn’t changed.

When are these companies going to learn?


Weird - What browser are you guys using?

I can’t change my password. I log in, and enter my password. I then go to change my password which requires my old password and 2 copies of a new password. Each time it gives me an error and says my old password is incorrect. I even logged out and then in again just to make sure in the few seconds I had somehow forgot my old password. It still refuses to let me change my password.

Here’s what I get:

There is a problem with this website’s security certificate.


The security certificate presented by this website was issued for a different website’s address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server. [/B]

We recommend that you close this webpage and do not continue to this website.

I did this successfully by NOT logging in at first. Just go to the account page, don’t log in, click forgot password. Enter your username, then you get an email with a link to another page at which you simply enter and re-enter a new password. So DeepT try starting over and simply give them your e-mail. Hopefully that’ll work.

I changed my password this morning in Firefox 7.0.1 with no issues.

Might that be a phishing link?

I’ve always ever gone to http://myaccount.turbine.com for any and all account/password issues.

Its on the main domain so, can it be a phishing link?

But yeah, I always google turbine and find them that way, or from ddo.com for instance.

Maybe we’re clicking different things.

When I go to turbine.com, if I click on the “Support” tab, I get:

http://www.turbine.com/support. Not the link reported up thread.

Then when I choose a game–LOTRO or DDO, I get this:


As soon as you want to go to do anything related to your personal account you do this:


Relatedly, I have three Turbine/LOTRO accounts on three different email addresses and did not receive any email on this yet.

Again, not an https link.

A thread on the official LotRO forums states that the email is false.

Guys, mouse over the link they give and your mail program will tell you it is NOT sending you to the support site.

It sends you to: email DOT turbine DOT com/ct/(numbers)

(address edited to make it non clickable)

So - where did the bad guys get our emails from?