Vista has "limited" connectivity to Airport

#1

New roommate has a laptop running Vista that’s having trouble getting to the internet.

I have the DSL router doing NAT, and an Airport Extreme base station in bridge mode providing the wi-fi.

My machine is running XP and connected via ethernet to the Airport so I’ve never had problems. My only wireless devices are iPhones and consoles, which I don’t have a problem with.

It doesn’t help that I don’t know my way around Vista.

I had the Airport set up with what I figure are pretty much the default settings, WPA/WPA2 Personal security. I gave him the key and he had no problem connecting to the Airport, but it only showed limited connectivity. Can’t actually get out to the internet.

I reset the Airport to default settings and recreated the whole network to be sure it was all defaults, and left it unsecured. Same thing, he could connect to the network but not the internet.

I googled a little and got random bits and pieces of who knows what kind of similar problems/solutions, and saw something about IPv6 that didn’t mean anything to me, but hey, there’s one more thing I can toggle.

The IPv6 options on the Airport are “Link-local only” (which is what it was on), Node, and Tunnel. I changed it to “Node” which adds the choice for Configure IPv6 Automatically or Manually. I left it on Automatically, updated the Airport, reconnected the laptop, and it worked! I could get to the internet.

So I figured that was the problem, so now I’d just go back and resecure the network, leaving IPv6 on Node. So all I changed once I had it working was reactivating WPA security. At which point it breaks again, and I’m back to “limited” connectivity.

HALP.

edit: And I’m reasonably certain I didn’t change anything about how the laptop was trying to connect, but I can’t rule out the possibility that in my fumbling through Vista maybe I did something slightly different in connecting at various points. If you know of any obvious mistakes there, please point them out!

#2

I’ve gone back and tried to recreate the settings that worked, and can’t even manage that. Makes it seem more likely I’m botching something on the laptop side and the one success had nothing to do with the IPv6 thing, but I really have no idea at this point.

#3

Somewhere in the Airport configuration, I imagine, will be something about DHCP. You should set the Airport to allocate IP addresses automatically (so DHCP on).

On the Vista laptop, go to the Network and Sharing Center, then click on “Change adapter settings.” Right click on the wireless card and select properties. In the menu that comes up, click on IPv4 settings. Make sure that the “Get IP address automatically” radio button is selected.

#4

sinfony is correct. “Limited connectivity” in Vista equates to “hey, I was able to join this radio signal, but I’m not getting an IP man, help me out here.”

Two things can cause this commonly, the device doesn’t do DHCP, or when you first connected to it with the Vista machine, you missed the pop-up that asked what security level the network is. By default it will deny access.

If your ipconfig shows something like 169.254.X.X, then it’s not getting a DHCP address. Delete that wireless network in Vista, shut down the machine completely, power back up, and attempt to rejoin that wireless network. You might also reboot your Airport, just to be on the safe side.

I almost forgot. Another trick you can do is disable wireless on the Vista machine, then plug it in via cable to the LAN. Once everything comes up, you get an address, and you confirm it’s a Home network or whatever, then and only then, unplug from the lan, and attempt to recreate the wireless connection.

#5

Just wanted to say thanks for the responses. My roommate wasn’t around yesterday, and today he came home and said the connection just started working after a reboot. Thanks, Vista!