Vistas DHCP suddenly broken after a move!

I’ve moved house, and moved my PC, and all is fine, my router is on the interwebs, and working fine. plugging my laptop into the new LAN cable that goes to the router works supremely, and it definitely uses the LAN because if I switch wireless off, it still happily connects.


If I connect my maiun desktop PC, it just gets that bullshit IP address that windows gets when it cant get a DHCP address. I tried all the ‘rebuild’ and ‘diagnose’ stuff but it achieved fuck all. There is only pone slot for the LAN cable, and I’m in it :D


If I try uninstalling the network card drivers, vista hangs. If I do ipconfig /release or /renew, it hangs.
The PC is set up to grab a DHCP address, and the router is happy to give them out. The router is some linksys crap.

Have you tried a system restore point from before the move?

If the LAN is on the motherboard, and the cable is working, it’s possible the motherboard got broken or just decided to malfunction during the move. If you have a USB wireless adapter, try that and see if it connects.

Here is how it got fixed, which is weird.

II unplugged it, moved the whole PC in the next room so I could use the same cable as before, and plugged it into the same socket on the PC, changing nothing else. It then worked.
I then moved the PC back, and used the longer cable as before, and it kept on working.
I literally changed nothing. I HATE computers. bah moan.