Windows Firewall, GamePass and UWP headaches

So kid wanted to play Minecraft Dungeons, so I thought, hey, I’ll finally sign up for that $1 month of GamePass and see whether it sticks. Much as I dislike the GFWL/XboxLive/whatever bloat, they do have a generous family share policy that allows us to play Bedrock Minecraft together on one license. So maybe I’ll even buy Dungeons on Windows Store after the month ends.

Problem is, outbound connections from Minecraft Dungeons is getting blocked by windows firewall (it does connect if I disable the firewall completely). I usually use Windows Firewall Control to set the rules which and the process is pretty brainless, but even manually tinkering with the rules have been fruitless.

So here’s a log of it being blocked. I’ve seen entries where it gets blocked and it references the actual \WindowsApp\ path as well.

I have the following rules set up:

The first two was added by WFC. The last is the manual rule, I’ve tried a number of things with the application package condition

Minecraft (Bedrock) UWP does work, I’m not sure what the difference is. Maybe this?

The permissions of the actual folder is set differently. Click on the “change” next to take ownership does nothing, while Minecraft Bedrock I actually get the change ownership dialog. So something is set differently there.

Eh, I could just disable outbound blocking whenever we play, but I’ve invested a bit of time into this and kind of want to see it through. Anyone deal with anything similar?

you’re overthinking it. allow it to prompt you after you run the game, allow it. then lock it back down.

Thanks, I did try that, when WFC prompts (twice) it creates the first two rules in this screenshot, which doesn’t work (still gets blocked). I tried removing all related rules and killing WFC and then starting dungeons, in the hopes of coaxing the Windows native “allow” prompt, but that prompt never shows up.

i reset my rules along with glasswire settings and tried to login to the game.

connectivity went to ( but it was stuck at the Live sign-in part
uninstalled it, reinstalled it and restarted it, it went to ( again, waited a while for the damn sign-in interstitial to appear and I was able to start an online session