Age of Empires: Definitive Edition install/patching problems?

I’m getting a 0x80073CF0 error every 2-5MB of download and haven’t been able to reinstall/patch it for days now.

Anyone else having this problem?

I suspect a CDN problem and wanted to confirm.

Just a note that I’ve forwarded this along to the store team involved. Thanks for the report!

Thanks @LMN8R wanted to confirm if anyone else was having the problem. Didn’t see carl’s posts before he withdrew them but was able to try the troubleshooting normally associated with Windows Store/Update w/o success.

Also had same problem after reverting to last week’s image and dozens of other UWP/Metro apps/games (Sea of Thieves) updated without problems leaving AOE the only problematic one.

It’s unrelated to anything or your system. It’s a publishing issue and will hopefully be resolved sometime soon.

Thanks for confirming my suspicions based on the nature of the problem.

I also saw it with a 40-50MB download/update of Dropbox Explorer with the same symptoms (it stopping every 500kb-1MB with an “error 0x800B0100 couldn’t install we’ll retry shortly” but that time I clicked retry through 50-times and while the 'x MB downloaded kept incrementing past 60MB it never stopped erroring ever megabyte.

I just wasn’t about to try the same for 17.5GB worth with AOE haha.


Same issue here in Brazil… im just buy Age of Empires Definitive Edition yesterday and just can even start download… error code 0x80073CF0 drops the initial download and can’t download / install the game… =( anyone knows whats happening with this issue? thanks! hugs from Brazil!

Same problem, Central Europe (Germany) here. Other updates from within the Store ran through just fine today. Just bought AoE:DE and can’t install, keeps erroring out every few Megabytes.

yeah this is a MS-Store end problem. also affecting Dropbox Explorer (random different app) …

man, after handling BITS and Windows Update and doing it at the OS level, I don’t know how the MS Store continues to be so bad with its cryptic error messages/lack of info.

I live in Germany an have the same issue (with aoe:de) , I contacted the support and i think it eill be fixed soon

I live in Italy and i have the same problem, i hope it’ll be solved soon

Same problem here for me.
Windows 10 Home 64 bits, high end pc.

Game used to run fine. An update poped. Couldn’t finish it.
Tried to uninstall game compltely and now i cannot download it at all.
Download instantly crash with notification saying the game could not be installed.

it likely won’t be solved soon since it’s a holiday long weekend. anyone hoping to play AOE should go play something else until next week.

I suggest Age of Empires 2.

Same issue here…

This one’s worthy of some venting on the “I fucking hate Games For Windows” thread.

Same problem here, after downloading 2 MB there was something unexpected en they would try agian. Hope they fix it soon. Luv from the Netherlands

On the bright side, this Age of Empire install problem seems to be single-handedly bringing a whole host of new people to Qt3. Welcome!

I’d forgotten how effective QT3’s pagerank was.

Looks like this is finally fixed.