DREDGE - Eldritch Fishing RPG! (2023)

twitch, can get there easily by harkonis.com as well.

Thanks for explaining the dredge mechanic to me on stream, Harkonis.

I ended up buying the gamethis morning on PS5. Why? I fired up the demo again on the Switch to play for a bit, thinking I’d confirm my interest. And the loading times were painful. Of course the PS5 is wonderfully fast, and I’m also finding that I’m a lot better at fishing on the PS5. I’m guessing because of the silky smooth 60 fps?

I played for several hours this morning and I have to say that the gameplay loop just works so well for me. Chill, fish, sell, upgrade, follow quests. And occasionally freak out because you stayed out too late and it’s fucking scary out there after dark.

I think I’m stuck…ish. I could probably finish with some persistence, but that feels a bit off. I’m going to put the issue in a spoiler tag. I’ve started over, which is fine since I missed a couple things in my first game anyway.

I don’t have enough research to get the rod with Abyssal on it, which I believe is required in order to get one of the relics. I had prioritized other things and made a bad assumption there would be enough research for everything. I think I can get research from the vendor as well as from dredging, but those seem RNG based and I need a lot. Did I miss a way to get a lot more research?

Also, just a warning, there are at least a couple timed quests that I found. The guys in robes that ask for fish will die if you don’t bring them back to them in time (not sure how long).

I’m really interested in this, is it Strange Horticulture levels of good, or Sunless Seas level? AKA is it that charming/interesting as I think with eldritch bits, or is it more Eldritch with a Rogue grind to it?

On the abyssal rod:

A quest giver will give you an abyssal rod, you’ll need to upgrade it to farm hydal, but the quest chain contains one research piece, so this shouldn’t be a problem

A separate spoiler regarding the one above

The quest giver you’re looking for is the researcher on the pirate isle, in the southwest corner. Her quest line is not terribly well-written, and you’ll need to go back to the research station twice to complete it, even if you thoroughly explored it the first time. I thought it was wanting me to dredge up the part, so i spent considerable time(and deaths) trying to fish/dredge up the piece, only to find it much later just sitting in the stupid station.

On the timed quests, they are particularly annoying since one of them (that i know of) can’t actually be completed until you have an abyssal rod, which i never got until it timed out. Poor quest-writing, but i’m hoping its not terribly important…

It’s…ok. It’s more of a relaxing vibe kind of game. I think it sets the mood right, and piloting your boat is remains fun throughout. I think it’s more like stray than anything - really cool to move through, but not quite solid as a ‘game’ game. Maybe baby’s first eldritch game? ymmv. But it does solidly get mood - has there ever been a game to convey so well that scene in jaws where they go out at night and hit the flood lights in the fog?

Thanks @pyrhic. I missed that.

I completely agree with the sentiment that it nails the mood, but isn’t really a solid ‘game’ game.

glad to hear it, I do think it’s a pretty chill, relaxing game with bursts of excitement.

MAJOR BUG: Don’t upgrade to the T4 hull!

You’ll lose everything that’s attached to your vessel (and maybe anything in your vessel too), more importantly, one of the things you lose is your dredge tool, which cannot be bought, so after you upgrade, you can no longer dredge. Apparently the devs are aware of this. Unfortunately, i ran into it, so i lost all my cool upgrades…

Yikes. That’s bad. I got lucky, I guess, and didn’t run into that when I upgraded.

Ouch. I got lucky too, on both my saves.

Finished it up. Really enjoyed the mood & story.

That didn’t happen to me, either. I’m playing the PS5 version. What platform did this happen on?

So far the game has been completely bug free for me, and my only annoyance is the no-warning timed quest to feed the robed person. No other quest in this game is timed, but suddenly this one had a hidden countdown? Boo-urns!

Loving the story, it’s really scratching my Lovecraftian itch. And I still get so much pleasure just fishing. I’m dawdling right now, in the final zone, with a fully upgraded vessel. I don’t want it to end! I keep just going back to the other zones and trying to fill out the fishcyclopedia.

Spoiler about abilities:

I really love the animations for the special book-learned powers. Especially Banish and Manifest!

PC, but reading through their discord it’s happened on other platforms too. Looks like they have a fix ready to go for it as soon as it’s through qa and testing…

You said it better than I could. This is one of those games I never knew I wanted, and it seems really well realized so far.

I’ve only gotten to the second zone. Maybe I’ll start getting annoyed when the timed stuff shows up, but for now I’m really enjoying it. What a great idea for a game.

The few timed quests are all the same (get a specific fish for the robed person on an unmarked island) and there’s at least 3 of the same quest, with robes of different colours. I’ve read on Reddit that failing these (or not doing them at all) does not impact any achievements / game completion as they do not go into the quest log. So my annoyance has waned.

After two days of playing nonstop, I’m at the final decision point. And I love that even on console I don’t need to save scum to see both endings. These devs know what gamers want!

Yesterday I saw a huge whale and later some dolphins breaching the surface. I was just putzing around. You couldn’t interact with them, but they were beautiful. The atmosphere in this game is just top notch.

Yeah I could probably live with that. I already “failed” one quest by selling a thing to the trader from a shipwreck that a grieving father wanted because it belonged to his son (I only picked up the quest after I sold it) but the game resolved it in a way that didn’t give me FOMO, so I’m okay with it.

I was on my first sail from the first zone to the second, and I just saw the fin of this giant thing in the water that was about 20 times bigger than my boat, and it was horrifying. It left me alone, but even just seeing it was terrible. Brilliant stuff!

I’ve played the PC version since launch day and completed it over the weekend. Took me about 16 hours. I’m not the fastest player, but I’d guess I tackled most of the quests. I failed the first of the four food fetch quests because I wasn’t aware those are timed. There’s a number of fish species undiscovered, and I’ll probably return to hunt down the last of the dogtags and see what the deal with the black altars is that didn’t respond to me touching them. I’d say it had the right length for me - it wasn’t irritatingly short, but didn’t overstay its welcome either.

I maxed out the ship build and did not encounter the bug pyrhic described and also didn’t notice any other obvious glitches so far. As for the research section, I went for all the upgrades except for the mini-engine and the biggest rod - the latter seemed to be a downgrade for me speed aside because I already had a setup (fathomless winch+ versatile rod) that covered all fishing scenarios while taking up less space.

I’ve had a good time with it and Dredge definitely had its “Ok, one more game day…” hooks in me. The exploration part brought back memories of Zelda: Wind Waker. In fact, I really want to play Wind Waker again now because that excitement you get when discovering a new island is so lovely. It’s a bit diminished in Dredge because the map doesn’t have any uncharted territory, but heading to a biome or island group one hadn’t visited before was thrilling regardless.

Biggest gripe probably would be the controls. Fine most of the time, but doing a camera turn to check behind you when/if you’re being chased something while trying to keep driving into one direction can be a pain because at some points the steering/acceleration inverts and you basically stop while trying to find a handle for the boat again. A bit frustrating when you’re trying to escape from something.

I’d agree with most of that, though maybe I’m more critical of it than you.

I’m mostly…annoyed…right now with my bug. I dare not do anything, because i have no idea what their fix is going to entail, whether it will restore everything (i very much doubt), whether it will wipe my ship again, or whether it’s nothing and means i need to start over (which i wont do). I’m probably about 2 hours out from completion, so it’s a shitty place to halt.

Apart from that, i found the controls, particularly the inventory controls, to be the worst. The click left stick to go to left inventory/right to go to right is about the most unintuitive thing I’ve run across in recent memory. I couldn’t count the number of times I clicked left and then clicked left again, thinking it will move it right, or moved all the way I wanted to go, only to reset myself by clicking the wrong control. But, ya the view/move controls are also kinda annoying (as is the brief pause to bring up the left menu)…

But, all in all, a nice little title that I wont play again, but was fun while it lasted.

I ended up remapping the stick presses to LT & RT. I couldn’t figure out how to get discard anywhere though, so I used the keyboard for that. I agree that default is not great.

Yeah, now that you mention that… it seems something built with mouse controls in mind because having to move over the controller cursor to always switch to the respective other side was cumbersome. It’s weird that they didn’t have a better solution for this since it’s not like this was an impossible problem to solve.

ya, i should try the m&k controls. Is the inventory management better with it? But i really enjoy piloting the boat with the controller…