Rebel Galaxy Outlaw

RTSS also comes bundled in MSI Afterburner, which I can recommend. I use it to monitor and limit FPS too.

Also, I’m getting over 60 FPS in RGO on G-sync monitor. Don’t think my settings are anything special, just have Vsync turned off in the game and in Nvidia’s control panel.

i have the ship Durston, are there more ships in the game, or is Coyote the last one?
i remember in Rebel Galaxy on PS4, there were maybe more ships, and bigger ones, i was hoping to get them in this game too.

Get the Ship Dealer built in Bountiful Vista for several more ships. If you love the Durston, you’ll REALLY love the Beluga.

Now that I’m near the end of the game I would really like to see a paid wormhole to go from one side of the galaxy to the other. I really hate to say this, but it’s getting a bit laborious and repetitive afterburn/warp, afterburn warp, afterburn/jump 8 or 10 sequences in a row. What you could have is a wormhole that costs like 50k to use. It’s a use for the excess money we have, and would give us a reason to do other missions again to try and make some more money if we get low on cash.

Thanks-- I think I tried that last thing (having the CP setting to off) yesterday but I’ll check it again.

blah blah blah wrong thread

As another datapoint, I’m getting 140 FPS on my Gsync monitor / 2080Ti setup.

I just confirmed I am seeing 60+ on my AOC G-Sync monitor with things set to 144 Hz refresh, V-Sync off.

To get FPS counter to appear, choose High for application detection level and Show own statistics to ON.

Eyyyyyy patch notes

Rebel Galaxy Outlaw
Patch 1.11 notes
~40MB

TECHNICAL
*Can now select full 4k resolution range properly even with display scaling, both in Fullscreen/Windowed Fullscreen

BALANCE
*Nerfed Infected Blockade mission
*Enemy swarm missile reload time doubled

INTERFACE
*Mining Laser shows proper GJ/s display for power drain in equipment bay
*Fixed a spelling issue in Beluga description
*KB/M controls now also ‘block’ held/released events on a menu state change (like gamepad/joystick do) to prevent issues like firing missiles on completion of a buddy summon

ART
*Some fancy new projectile artwork
*Fixed an NPC’s collar weighting
*Fixed a clipping spinning station chunk in Topeka concourse

BUGS
*Fixed a corner-case where you could have an invisible bountry retrieval after failing or abandoning but then picking them up anyway. (They will now re-expose themselves in your hold if they were in that state, no action required)
*Fixed a pool issue where you could manage to fire a ‘move ball’ event while the cue was in motion for a strike.
*Fixed rare corner-case crash involving an automated mission-docking when the player managed to get to sublight just as it occurred

MISC
*Altered phrasing on some scouting missions not to imply that targets must be killed.

YAY, more patches! You getting any sleep at all these days? ;-)

Anyway I finally resolved my fps issue. Don’t know how I didn’t see this earlier but it looks like I had the game set to launch windowed full screen. Have no memory whatsoever of doing that. Maybe my finger slipped at some point. I feel like an idiot now. D’oh!

And thanks, @rei, for following up. Is that tool free?

Yes, it’s free. I can’t get it working presently in The Division 2 but people more expert than me swear by RTSS vs. using games’ built-in frame limiters. Something something about 3 fps than desired. So, 57 fps (set via the tool on the screen I showed) if you want 60. I used it for AC Odyssey to maintain stable framerate last.

Cool!

I’m running in windowed full-screen too.

Right-click on the desktop, select ‘Display Settings,’ click on ‘Advanced Display Settings’ near the bottom of the window. Note the refresh rate listed.

If it’s 60 Hz, change it. Click on ‘Display adapter properties.’ In the new window, click on ‘List All Modes.’ Should look like this:

Monitor

Select the mode with the maximum refresh rate your monitor can support.

Thanks for the detailed explanation. It seems to be set to 150 Hz right now (which matches what I’ve set it at with the buttons on the monitor), although per ASUS, the monitor can do 165. Does it have to be set at the maximum the monitor can support, or can it be a bit less?

Your desktop monitor refresh must always be set to max if you want to take advantage of G-Sync in games. Having Windows desktop refresh at 60 Hz prevents that from happening.

I finally remembered who Juno reminded me of:

image

Wha? I wouldn’t think that would matter. You don’t have to run your monitor at it’s maximum refresh, and if your FPS is never getting above 50 on a 60hz it wouldn’t matter. Now if your refresh rate is hitting 36 then Gsync starts having to insert duplicate frames. With that said there is little reason not to put it at max.

If you want to make sure Gsync is running at it’s best then Vsync off in games, Vsync on in the nvidia control panel, and if the game has a frame limiter set it to 2-3 fps below your default refresh rate. The reasoning behind all of the above is amazingly complex and would be best served by going over to blurbusters - https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/15/

This is the part that confuses me. Nvidia added an “adaptive” option to vsync. Is this the correct setting for g-sync now?

image

I always thought you kept Vsync off at all times when using Gsync. That’s always worked fantastic for me, anyway, so I don’t see a need to change that.

It used to be the case, but they made it so you don’t have to any more, you can either keep it on or not. But it’s only really a benefit at super high frame rates above your monitor’s max refresh. Adaptive V-sync seems to be an Nvidia tech that Gsync renders superfluous.