Starflight 3!

Wasteland 3 used Fig without any problem. It wasn’t the platform, IMO.

What hurt them most in regards to exposure was themselves.

Fair enough.


OK, I also have the version of Starflight, and you’re right, the code has changed. But not a lot, near where the original patch used to go. Assuming that the version is using the same revised diskettes that you have, try this new patch I whipped up. I tested it using DOSBox in Tandy mode; hopefully it will work for you.

As always, work with a copy of the diskette, never your original.

Follow the instructions of my decades-old patch to start DEBUG, then:


Now verify that we have the version we’re expecting:

d 8db5 l e

should show

xxxx:8DB5  BA D4 03 BE 5C 8C E8 83 FE 83 3E EC 84 01

(The output may be spread across two lines.) If you don’t get these values, you have a different version. If it matches, you can proceed:

e 8db5 b8 08 00 cd 10 06 0e 07 ba c8 8d b8 02 10 cd 10 07 eb 1f


u 8db5 l 13

should show:

xxxx:8DB5 B80800        MOV     AX,0008
xxxx:8DB8 CD10          INT     10
xxxx:8DBA 06            PUSH    ES
xxxx:8DBB 0E            PUSH    CS
xxxx:8DBC 07            POP     ES
xxxx:8DBD BAC88D        MOV     DX,8DC8
xxxx:8DC0 B80210        MOV     AX,1002
xxxx:8DC3 CD10          INT     10
xxxx:8DC5 07            POP     ES
xxxx:8DC6 EB1F          JMP     8DE7


e 8dc8 00 02 01 03 04 08 05 09 06 0a 07 0b 0c 0e 0d 0f 00


d 8dc8 l 11

should show

xxxx:8DC8 00 02 01 03 04 08 05 09 06 0A 07 0B 0C 0E 0D 0F
xxxx:8DD8 00

Write the file out and quit DEBUG:


Let me know if this works! Hopefully there aren’t any transcription errors.

Once again, this is amazing work, thank you! Unfortunately I’m still not up and running. I think the version is correct, as I got the right results displaying the 8DB5 sequence at the start of your directions. I applied the patch, double checking everything as I went. When I booted up the game, I chose graphics mode 3 for Composite, but still got the same black and white jumble of blocks as I got before I applied the patch:

I still think this new patch is going to be what gets me up and running, even if it didn’t work with these floppies for whatever reason. Once I receive the SD card adapter that I’ve ordered, I’ll be able to try bringing the GOG version over and seeing if that works.

As I understand it, the patch won’t work if there’s an existing save game, right? I certainly haven’t saved a game, but I have tried booting it from these floppies before. Would that be enough to mess up the patching process? Or I suppose it’s possible there’s just something corrupt on the disk?

Either way, I can’t express enough how appreciative I am of your help.

All the best!

I had that display, and never saw that from the game. My display would just lose sync when the game ran. I’m thinking there’s some other problem here. Some things I’d check, off the top of my head:

  • It may be that running the game from the original disks has altered files. If I recall correctly, the patch needed to be applied to a fresh copy of the original disks, before running the game.
  • Enough memory? The game needs a PCjr with at least 256K of RAM.
  • PCJRMEM.COM configured correctly on your boot diskette?
  • There’s also a possibility you have bad RAM, though I don’t know what software you’d use to check it on a PCjr today.

This is DOSBox pretending to be a PCJr, running the patch I posted last night:

Thanks for the troubleshooting tips.

I don’t think RAM is the issue, though I wouldn’t completely rule it out. My system has 640K, and I’ve confirmed other games that need 256K+ will run properly.

I can’t say if the original floppies were ever modified or written to. They’re write protected, but still hard to be certain all the same. I kind of suspect there’s some bad data there.

My current gameplan is to wait for the SD cartridge adapter, then try the patched GOG version. I’ve rarely been this excited for a package to arrive. I’ll let know know how it works out. Hopefully that won’t be too much longer. Given it’s coming from Japan, during a pandemic, and with the Suez Canal mishap thrown in, I’m fine being patient.

Thanks for sharing the screencap by the way. Good to see what it looks like on the system. Love the lego-brick pixels.

You gotta love the 160x200x16 colour glory going on there. For what it’s worth, that’s the resolution you saw on any video card. Please let us know how you make out when you can generate some new diskettes!

I guess this is the closest thing we have to a Starflight thread around here, this article just turned up in my newsfeed. It’s pretty good.

That was a fantastic read, thank you!

I played the Mac versions of Starflight 1 and 2 in glorious 640x480 resolution. I want to say it was in 8-bit color as well, but I’m not sure about that.

Makes me wonder how the Mac version was ported, as I can’t see the original code driving those sorts of graphics without a major rewrite… unless it was just doubling or quadrupling pixels.

It is still one of my favorite things that Starflight was written in Forth.

It may be just my rose-colored glasses talking, but I remember it looking vastly superior to a DOS version a friend of mine installed but kept crashing, pretty close to the same time I played the Mac version (ca. 1991 and 1992).

I love that too. I have a thing for niche programming languages.

There was a time in college where I was simultaneously obsessed with the SmallTalk programming language and civil war history and tried to recruit some friends to build a game like the old Run5 games but more real time (basically Sid Meier’s Gettysburg before that was a thing) and write it in Smalltalk. For better or worse after some discussion they rightly concluded I was mad and this would cut too much into our Empire and Star Control Melee playing time.

It works! Took me a while to get the SD-Cart adapter up and running (had to buy a copy of DOS 5 on ebay in order to format the card), but it works!! I used the GOG version of the game and applied the patch just as you instructed.

Now I can finally try out this classic game on the original hardware!!

Thank you!!!

Woohoo congrats dude. That is a gorgeous site to behold, truly.

Oh wow, I had that exact joystick I used to play with my TRS-80.

Far out. Check out that mouse BTW. I bet it has a rubber ball in it and everything (I do not miss having to scrape off the crud that would build up on the rollers).

Actually no, that looks optical! Advanced!

Excellent! I’m glad it worked. You’re in for some fun now!