Subnautica - SCUBA, Unknown Worlds, drowning


This will make Sonky very happy.


test dive


Huh? It’s on the PS4?


Indeed! Well played sir.


Oops, meant Xbox. I go between them a lot and got mixed up.


Hah, gotcha. I like the idea of this game, but was turned off by the awful performance on the Xbox. Very inconsistent frame rates, plenty of pop-in, and even some audio weirdness that makes me wonder if it’s an intentional or glitched sound effect.

I’ll revisit it on the PC someday, or on the Xbox if the situation improves, but for now performance issues make it hard to recommend the console version.


Looks like the July 6 (Micro) Update 67 included optimizations for the Xbox version which they say will also benefit “at or near minimum-specification” PCs (better frame rates) among other things.


Not this one either?


Either way; I’m naming mine “Pepe”.


Oh cool. Wish I could do the one hour demo thing again to see how things are improved.


Well my glitchy experience was just a couple of weeks ago so still not perfect I guess. I don’t remember if there were other issues though. I do hope they get it all sorted out though as I really want to play.


Dangerous Creatures Update


Saw this was updated on Steam, it’s too bad it work in VR for me. I’m still waiting for the update that fixes that.


I already bought this in a sale a few months ago, but don’t like playing pre-release games. Still it keeps calling to me. How close is it to 1.0 at the moment?


Story mode and 1.0 is early next year. They have a roadmap up here:

Looking at that roadmap , everyone who gets the game before 1.0 gets a in game pet fish! LoL.


I’m totally in for a pet fish and so is the cat.


Have you tried all the troubleshooting stuff?

For me, it fires up near instantly to the menu in VR. When loading or starting a new game it sits for about a minute on a black screen, but you can see the loading screen on the monitor mirror which judders around a bit as you move your head. If it sticks here, have you tried leaving it for at least five minutes? I recall this happened for me once ages ago, but was okay after that.

Did you do a ‘Verify Integrity of Game Cache’? Try deleting the root folder files, then verify the game cache. Then delete (or rename) the options.bin file in the Subnautica\SNAppData\SavedGames\ folder.

If it doesn’t work, try posting on their forums rather than waiting and hoping for a fix.


Yeah I tried all those. I get exactly the same loading issues except mine doesn’t resolve in 5 minutes. I’ve read on the forums people waiting upwards of 30 mins and I’ve got no time for that. It’s still EA so hopefully they get this stuff figured out, even waiting 5 minutes is kind of nuts. Anyway there’s lots of other games to play.


Maybe try leaving it for 30 minutes or more? From experience, the lengthy wait was a once-off thing. Maybe a full re-install? :)

I looked on their issue tracker and didn’t see the problem listed anywhere, which is why I mention hitting up their forums to make sure it gets some attention. Which is odd though, since it does mention it in the troubleshooting section on Steam. :P


Well, now I know not to get my hopes up every time I see this thread bumped. At least not until next year.