The forum maintenance thread

No it was us. I believe I fixed it. Actually the restart should have fixed it for a long time, but I believe I addressed the root cause also.

Ah, well. He’ll be ok then, anyway. I did my best. :)

Us, to any DBA or apps team, on any project, ever: “What would you say is the amount of memory needed for the database?”
Them: “Yes, all of it, everything.”

Then we get to play the, “Let me show you my pokemans,” game where we explain how shared memory works in a VM or cloud environment and what all is actually running there.

So now the tables have turned. We want more memory, Stusser! As part of QT3, now I’m part of the assholes. Yay!

Yea! I’m back in!

I was worried about you, man.

wow how dumb am I to mute the games category? Takes talent. Thanks for the correction folks.

@stusser, are you feeding the Tapirs again? Things are running kinda slow…and weird.

Seems fine to me homie. And no monitoring alerts.

This post just posted in <1 second, which is far better than than 3-5s it was taking a couple days ago.

Yeah, it seems fine now. One issue: the right panel preview when I reply here? It’s gone. Nothing shows up.

Weird. I’m looking at a right panel right (sic) now while typing this. Empty your cache, restart your browser, sacrifice a goat to Beezelbub, the usual stuff.

The Goat/Dark Lord Step in the troubleshooting guide worked.


Is QT3 having trouble today? Constant errors on page loading.

Im getting 502 error JUST on the board game 2018 thread. Tried restarting IE, using chrome, and shift refresh and multiple computers and different networks (work and home)…same problem!

I was getting the same thing yesterday morning (Eastern time.) Even within the same forum, I could post on some threads, not others. It appeared to be between the web front end and whatever the database backend is.

Paging @stusser

I believe @clay was opening a bug report on this.

Nothing out of spec on monitoring or logging?

Not that I can see, Discourse is largely a black box to me.

I think it’s a bug. @stusser if you visit the logs page, I think it’s the error at the bottom. I don’t know why it happens to some people and not others. @David2 were you trying to post an image or anything?

I think one of the unicorn workers gets corrupted or something.

Edit: or maybe that’s an error generated by the Admin dashboard? It calls Synth and Stusser out by username.

Beats me, I don’t know ruby or postgres.