The way games display on Mac vs. PC

So my friend has a 17" widescreen PowerBook (or something recent and nice, dual core), and when he runs Fallout 2, OS X displays black bars on the sides and keeps the aspect ratio of the game, which runs at 640x480.


On my PC though, if I want to run a game that’s NOT widescreen enabled (like Battlefield 2) on my widescreen monitor, it stretches it out horizontally, making it look all crazy. Is there any way to get black bars on the sides of my screen like on the Mac OS?

I’m running Vista 32, and planning to install XP again over the weekend.

Go into your video card settings, look for an option labeled something like “fixed-aspect ratio scaling,” enable it. In nVidia’s control panel, it’s under “change flat panel scaling.”

Have they fixed flat panel scaling yet? It’s been broken in nVidia’s drivers for years.

Seems to work now.

I’ve used both native scaling (using the panel’s scaling) and the Nvidia scaling. Both look correct, though I haven’t actually taken out a ruler and measured it, mind you. ;-)

Macs can do this because they always know what the display is.

Though you can argue that all laptops should be able to do this.

Here’s the general rule of thumb:

On displays that are 1920x1200 or less, set the graphics card control panel to scale to the correct aspect ratio. You can either have the graphics card scale or the display scale. On cheap displays, you’ll get better quality if you let the graphics card scale. On high end displays, the scaler built into the display is usually pretty good, so I let the display scale.

On 30-inch, 2560x1600 displays, you can only have the graphics card scale. (Well, there are one or two 30-inchers with built in scalers, but they’re fairly rare and usually very expensive.)

What drives me nuts is whenever I install a new driver (and this seems to be true for both Nvidia and ATI), they reset to stretch the image. Please, driver guys, leave my aspect ratio be!

Now if only there was a way to automatically fix top-posters.

I have found the issue is NOT fixed for me. In fact, all scaling options are grayed out now except for the one that just stretches the display (yech). I’m using a Samsung T240 monitor. What Nvidia drivers are you using? I’ll be able to verify which ones I’m using when I get home.

It works fine on my NEC LCD2960W2Uxi (26-inch, 1920x1200).

When you say “grayed out”, do you mean the monitor controls, or the Nvidia controls? I’m running the latest Vista 181.22 drivers.

I recall a problem with Dell displays (I believe some use Samsung panels) in which the display scaling control wasn’t accessible unless you were running at some resolution lower than the native panel resolution. If you set your resolution to something lower than native, you could then set panel aspect ratio scaling. It would “stick” when you returned to the native resolution. Dunno if that’s the case with the 240T.

This is what I see in the flat panel scaling options:

Happens with the 180.84 drivers for me. Haven’t tried the 181.22 so I’ll try those next. Thanks!

I’m running 181.22 with a Dell 2408wfp (1900x1200) and all scaling options are selectable. I’ve never had a problem with them not being selectable on earlier driver versions, though, so maybe your driver version isn’t the thing that is causing them to be greyed out.

I don’t recall which drivers they were but the set I had been using previously did allow me to select from any of the scaling options, it just wouldn’t stick, always reverting to the monitor scaling no matter which I picked. The grayed out thing is new. If it’s not simply a driver glitch I will be a sad (and badly scaled) panda.

Updated to the 182.05 beta drivers (the ones that boost FEAR 2 performance) and scaling options are still grayed out. I have Driver Cleaner so I may do another uninstall/install using that but I think I’ll use teh Google first to see what else I can dig up on this.

they only appear if you use dvi and not analog dsub15.

I am using DVI. Could having the 360 plugged in through the HDMI port be messing it up somehow?

if the drivers don’t give you satisfaction (having 20+ video cards in last 4 years) i know that the drivers sometimes lose/add this damn feature or other features every other revision :/

Yeah, the scaling has been buggered for so long I had written it off actually working correctly, but Loyd’s post gave me hope that maybe it had been fixed (for everyone).

On the plus side, the 182.05 drivers did fix the corruption with shadows when running LOTRO in DX10 mode.

as a fallback, maybe your monitor has 1:1 pixel mapping/scaling mode you can set it to. my benq and dell ultrasharps did.

The scaling options have worked fine for me since they’ve existed, with a couple of different nvidia-based desktops, a laptop (also with an nvidia GPU) and multiple monitors used in that time period and dozens of driver updates across all of them.

I’m guessing that for people for whom it is buggered there must be some extra factor to it that doesn’t hit everyone, such as your monitor drivers or something. Googling shows that you certainly aren’t alone with this issue (though most references seem to be pleas for help with no solid response, sorry), but I’ve been blissfully unaware such an issue even existed because my systems appear to be immune to whatever the buggering thing is.

Yeah, it’s flat panel scaling for flat panels. If your panel is not flat, there is nothing here for it :)

The thing is that scaling worked fine a couple of years ago. After a certain driver release, it stopped. I think things might be different in the Vista drivers, but I haven’t bothered with it in a while. Go back to the old drivers, and currently broken scaling starts magically working again. Glue bits of the old control panel onto the new drivers, they work again.

In other words, nVidia DISABLED flat panel scaling under certain conditions. What those are, noone knows. It’s sometimes possible to hack support back in, but would you want to use 155 and 181 driver bits glued together?

Anyway, go Mac :)

The scaling on my Asus Eee works just as awesome. I suppose that that’s the part of graphics development Intel has done right.

Ati also provides built-in support for flat panel scaling. On my 1680x1050 monitor, this only works as advertised for the 1400x1050 resolution, making it almost completely useless (if a game supports 1400x1050, chances are immense that it also supports widescreen).